Kuinka käyttää IF-toimintoa

JOS-toiminto on yksi suosituimmat Excel-toiminnot . Funktio palauttaa yhden arvon, kun ehto on tosi, ja palauttaa toisen arvon, kun se on epätosi.

Kaava:

= JOS(looginen_testi, arvo_jos_tosi, [arvo_jos_epätosi])

Selitys:

– Looginen_testi vaaditaan, testattava ehto.

– Arvo_jos_tosi on pakollinen, arvo, joka palautetaan, kun looginen_testi on TOSI.

– Arvo_jos_epätosi on valinnainen, palautettava arvo, kun looginen_testi on EPÄTOSI.

Varoitukset:

– Funktio palaa arvoon 0 (nolla), kun arvo_jos_tosi- tai arvo_jos_epätosi-argumentteja ei ole

– Funktio palauttaa #NAME? virhe, kun kaava on kirjoitettu väärin.

= JOS(A2=A3, 'sama','erilainen')
= JOS(A3=A4, 'sama','erilainen')

Jos A2 = A3, funktio palauttaa 'sama', muussa tapauksessa funktio palauttaa 'erilainen'. 'Excelnotes' A2:ssa on sama kuin 'Excelnotes' A3:ssa, tulos palauttaa 'sama'.

Jos A3 = A4, funktio palauttaa 'sama', muussa tapauksessa funktio palauttaa 'erilainen'. 'Excelnotes' A3:ssa eroaa 'Excelnotes.com' A4:ssä, tulos palauttaa 'erilainen'.

Lataa: IF-toiminto