Kuinka löytää kaksoiskappaleita kahdesta sarakkeesta

Ehdollinen muotoilu | IF-toiminto | Useita vierekkäisiä sarakkeita | Useita sarakkeita | Vlookup-ottelu

Kun työskentelet suuren tietokannan kanssa, saatat löytää useita kaksoiskappaleita yhdestä sarakkeesta tai useista sarakkeista. Kaksoiskappaleiden tunnistaminen ja poistaminen on ratkaisevan tärkeää tietojen puhdistamisessa ja analysoinnissa. Seuraavassa on menetelmä kaksoiskappaleiden etsimiseen ja poistamiseen kahdessa sarakkeessa. Katso seuraavat kaksi viestiä, jos haluat löytää kaksoiskappaleet yhdestä tai useammasta sarakkeesta.

– Kuinka löytää kaksoiskappaleita yhdestä sarakkeesta
- Kuinka löytää kaksoiskappaleita useista sarakkeista



1. Ehdollinen muotoilu kaksoiskappaleiden löytämiseksi kahdesta sarakkeesta

Oletetaan, että löydät seuraavan esimerkin sarakkeen A ja sarakkeen B päällekkäiset arvot ja muotoilet kaksoiskappaleet sarakkeessa A, jos kaksoiskappaleet ovat sarakkeissa A ja B.

Vaihe 1: Korosta sarake A;

Vaihe 2: Siirry kohtaan Koti Välilehti, napsauta ' Ehdollinen muotoilu 'kohteessa Tyylit osio ja napsauta sitten ' Uusi sääntö… ';

Vaihe 3: kohdassa ' Uusi muotoilusääntö ' -ikkunassa 'Käytä kaavaa määrittääksesi, mitkä solut muotoillaan' ja napsauta sitten 'Muotoile arvot, joissa tämä kaava on tosi' -ruudussa solua A2 , kirjoita sitten = ja napsauta sitten B2 '.

Vaihe 4: Muuta absoluuttinen arvo suhteelliseksi arvoksi: muuta kaava '=$A$2=$B$2' muotoon ' =A2=B2 ', napsauta sitten ' Muoto ';

Vaihe 5: kohdassa ' Uusi muotoilusääntö '-ikkunassa, voit valita Fontin väri tai valitse solun väri Täyttää Ikkuna.

Vaihe 6: Napsauta OK , sarakkeen A päällekkäisten arvojen väriä muutetaan.

Vaihe 7: Jos sinun on löydettävä yksilöllinen arvo, muuta kaavaa =A2=B2 kohtaan =A2<>B2 .

2. Kuinka käyttää IF-toimintoa Etsi kaksoiskappaleet kahdesta sarakkeesta

Vaihe 1: Luo apusarake ja kirjoita kaava =JOS(A2=B2'Kaksoiskappale','Ei kaksoiskappaletta') ensimmäisessä solussa;

Vaihe 2: Kopioi alas. Riveillä, joilla on kaksoiskappaleita sarakkeissa A ja B, näkyy 'Duplicate' ja ei-kaksoiskappaleissa 'Ei kaksoiskappaletta'.

Vaihe 3: Huomaa, että yllä oleva kaava on EI kirjainkokoa (esim. Jason on sama jason). Jos haluat löytää arvoja, jotka vastaavat tarkasti isot ja pienet kirjaimet , voit käyttää kaavaa =JOS(TARKKA(A2,B2),'Kaksoiskappale','Ei kaksoiskappaletta')

3. IF-funktion käyttäminen kopioiden etsimiseen useista vierekkäisistä sarakkeista

Oletetaan, että sinulla on 4 tietosaraketta ja sinun on löydettävä kaksoiskappaleet, kun mitkä tahansa kaksi vierekkäistä arvoa rivillä ovat samat.

Vaihe 1: Luo apusarake ja kirjoita kaava =JOS(TAI(A2=B2,B2=C2,C2=D2), 'Kaksoiskappale','Ei kaksoiskappaletta') ensimmäisessä solussa;

Vaihe 2: Kopioi alas. Riveillä, joilla on kaksoiskappaleet missä tahansa kahdessa vierekkäisessä sarakkeessa, näkyy 'Duplicate' ja 'ei kaksoiskappaleet' -teksti.

4. IF-funktion käyttäminen kopioiden etsimiseen kahdesta sarakkeesta

Oletetaan, että sinulla on 4 tietosaraketta ja sinun on löydettävä kaksoiskappaleet, kun mitkä tahansa kaksi arvoa rivillä ovat samat.

Vaihe 1: Luo apusarake ja kirjoita kaava =if(tai(a2=b2,b2=c2,c2=d2,a2=c2,a2=d2,b2=d2),'Kaksoiskappale','Ei kaksoiskappaletta') ensimmäisessä solussa;

Vaihe 2: Kopioi alas. Riveillä, joilla on kaksoiskappaleita missä tahansa kahdessa sarakkeessa, näkyy 'Duplicate' ja 'ei kaksoiskappaleita' -teksti.

merkintä: löytääksesi arvot yhdestä sarakkeesta, mutta ei toisesta sarakkeesta, katso VLOOKUP-toiminto .

Lataa esimerkki kaksoiskappaleesta