Kuinka muotoilla numerot M:ksi tai miljoonaksi

Suuret luvut pyöristetään usein miljooniksi tai yksinkertaisesti numeroiksi, joissa on kirjain 'M' tai sana 'miljoona'. Esimerkiksi 4 569 885 on 4,57 miljoonaa tai 4,57 miljoonaa. Tarkista kuinka muotoilla Axis-tunnisteet miljooniksi jos työskentelet kaavion kanssa.

1. Lisää 'M'

Jos haluat muuttaa suuren luvun arvoksi 'Numero + M', voit käyttää alla olevaa kaavaa.



=TEKSTI(A2'#.00,, \M')

Missä '#.00' pitää tuloksena 2 numeroa.

Kaava on muuntaa luku miljooniksi lisäämällä kirjain 'M' loppuun yleisen pyöristyssäännön mukaisesti. Kun satatuhannen numero on 5 tai suurempi, luku pyöristyy ylöspäin, ja kun satojentuhansien numero on pienempi kuin 5, luku pyöristetään alaspäin.

2. Yhdistä 'Million' tai 'M' kanssa

Toinen tapa on pyöristää suuret luvut ensin lähimpään miljoonaan ja sitten yhdistää 'Million'-työhön CONCAT-toiminto alla olevalla kaavalla.

=TEKSTI(A2/1000000,'#,###,###.##')&'Miljoona'

tai muuttaa 'Million' arvoksi 'M' seuraavalla kaavalla.

=TEKSTI(A2/1000000,'#,###,###.##')&'M'

Huomaa, että kun luku on pieni, luku pyöristetään ja tulokseksi palaa '.Miljoona'. Välttääksesi tämän tilanteen, käytä IF-toiminto ehdoittamaan sitä. Jos esimerkiksi haluat säilyttää 2 numeroa, 5 000 pyöristetään 0,01 miljoonaksi. Kaikki alle 5 000 olevat luvut ohitetaan.

Jos käytät Excel 2016:ta tai sitä vanhempaa, voit käyttää IF-toimintoa seuraavasti:

=JOS(A2<5000,'',JOS(A2>=5000,TEKSTI(A2/1000000,'#,###.##')&'M'))

Jos käytät Excel 2019:ää tai sitä uudempaa, voit käyttää IFS-toimintoa seuraavasti:

=IFS(A2<5000','A2>=5000,TEKSTI(A2/1000000,'#,###.##')&'M')