Kuinka purkaa ensimmäiset neljä sanaa

Poimiksesi neljä ensimmäistä sanaa tekstimerkkijonosta sinun on löydettävä neljännen välilyönnin suhteellinen sijainti ja käytä sitten Vasen toiminto .

Kaava:

Kopioi kaava ja korvaa 'A1' solun nimellä, joka sisältää tekstin, jonka haluat purkaa.



=JOS((PITOA(A1)-PITO(KORVAA(A1,' ','')))<4, A1, LEFT(A1, ETSI(' ',A1, ETSI(' ',A1, ETSI(' ') ,A1, ETSI(' ',A1)+1)+1)+1)-1))

Esimerkki:

Poimi ensimmäiset neljä sanaa tekstimerkkijonosta ' Kuinka purkaa ensimmäiset neljä sanaa '.

Tulos palauttaa neljä ensimmäistä sanaa ' Kuinka purkaa '.

Selitykset:

Vaihe 1: Ensimmäisen tilan sijainnin löytäminen

Kaava =ETSI(' ',A1)
Tulos 4

Vaihe 2: Toisen tilan sijainnin löytäminen

Kaava =ETSI(' ',A1, ETSI(' ',A1)+1)
Tulos 7

Vaihe 3: Kolmannen tilan sijainnin löytäminen

Kaava =ETSI(' ',A1, ETSI(' ',A1, ETSI(' ',A1)+1)+1)
Tulos viisitoista

Vaihe 4: Neljännen tilan sijainnin löytäminen

Kaava =ETSI(' ',A1,ETSI(' ',A1,ETSI(' ',A1, ETSI(' ',A1)+1)+1)+1)
Tulos 19

Vaihe 5: Poimi kirjaimet ennen neljättä välilyöntiä

Kaava =VASEN(A1,ETSI(' ',A1,ETSI(' ',A1,ETSI(' ',A1, ETSI(' ',A1)+1)+1)+1)-1)
Tulos Kuinka purkaa

Kun tekstimerkkijonossa on vähemmän kuin neljä sanaa, kaava '=LEFT(A1,FIND(' ',A1,FIND(' ',A1,FIND(' ',A1, FIND(' ',A1)+1)+1 )+1)-1)' palauttaa #ARVO! virhe. Tämän virheen välttämiseksi sinun on yhdistettävä IF-toiminto .

=JOS((PITK.(A1)-PITK.(KORVAA(A1,' ','')))<4,A1,VASEN(A1,ETSI(' ',A1,ETSI(' ',A1,ETSI(' ') ,A1, ETSI(' ',A1)+1)+1)+1)-1))

=KORVAA(A1,' ','') korvaamaan välilyönnit tekstijonossa;

=PITKÄ(KORVAA(A1,' ','')) laskea tekstimerkkijonon pituuden, kun välilyönnit poistetaan;

=PITO(A1)-PITO(KORVAA(A1,' ','')) laskea välilyöntien määrän tekstimerkkijonossa.

Lataa esimerkki