Tuhannen muotoileminen K- tai Word Thousand -muotoon kaavan mukaan

Kun työskentelet suurten numeroiden kanssa, sinun on usein tarpeen lisää tuhannen erotin . Joissakin muissa tilanteissa saatat haluta muuttaa tuhannen K:ksi monien nollien sijaan. Esimerkiksi 10 000 - 10 000.

1. Muuta K:ksi

Käytä alla olevaa kaavaa muotoillaksesi tuhannesta 'K':

=TEKSTI(A2'#.00,K')

'#.00' tarkoittaa kahden desimaalin tarkkuutta.

Jos haluat myös lisätä tuhannen erottimen muuntaessasi tuhansia 'K:ksi', käytä alla olevaa kaavaa.

=TEKSTI(A2'#,###.0,K')

2. Muuttu tuhannen työksi

Toinen tapa on pyöristää suuret luvut lähimpään tuhansiin ja yhdistää sitten 'Tuhannen' työhön seuraavalla kaavalla.

=TEKSTI(A2/1000,'#,###.##')&'K'

tai lisää sana ' tuhat 'numeron jälkeen.

=TEKSTI(A2/1000,'#,###.##')&'tuhatta'

Huomaa, että kaava muuttuu muotoon '.K' tai '.thousand', kun luku on pienempi kuin 5 ja sinun on säilytettävä 2 desimaaleja. Tämän välttämiseksi voit yhdistää IF-toiminto kuntoon Excel 2016:ssa tai aiemmassa versiossa.

=JOS(A2<5',',JOS(A2>=5,TEKSTI(A2/1000,'#,###.##')&'K'))

Jos Excel 2019:ssä ja sen jälkeen, IFS-toiminto helpottaa tilannetta huomattavasti.

=IFS(A2<5','A2>=5,TEKSTI(A2/1000,'#,###.##')&'K')